aboutsummaryrefslogtreecommitdiffstats
path: root/fg21sim/configs/00-general.conf.spec
diff options
context:
space:
mode:
authorAaron LI <aaronly.me@outlook.com>2016-10-04 14:56:52 +0800
committerAaron LI <aaronly.me@outlook.com>2016-10-04 14:58:21 +0800
commit1e0d443c4c77a8a2cc0ae6e503e8811aca6b3e39 (patch)
treebdf3abce08cddcceff7bf9c8fec3dd9ace17d1cd /fg21sim/configs/00-general.conf.spec
parent84edeab1f585aa07a36bc060f22ede812abf9669 (diff)
downloadfg21sim-1e0d443c4c77a8a2cc0ae6e503e8811aca6b3e39.tar.bz2
Fix wrong config syntax and minor changes to ConfigManager
Diffstat (limited to 'fg21sim/configs/00-general.conf.spec')
-rw-r--r--fg21sim/configs/00-general.conf.spec8
1 files changed, 4 insertions, 4 deletions
diff --git a/fg21sim/configs/00-general.conf.spec b/fg21sim/configs/00-general.conf.spec
index ab36f52..6827a12 100644
--- a/fg21sim/configs/00-general.conf.spec
+++ b/fg21sim/configs/00-general.conf.spec
@@ -11,15 +11,15 @@
[common]
# HEALPix N_side value, i.e., pixel resolution
# NOTE: also update "lmax" below.
-nside = int(min=1, default=512)
+nside = integer(min=1, default=512)
# HEALPix ordering scheme
ordering = option("RING", "NESTED", default="RING")
# Range of multipole monents (l) of the angular power spectrum.
# The power spectrum will be cut off to a constant for multipole l < lmin.
# Generally, lmax = 3 * nside - 1
-lmin = int(min=0, default=10)
-lmax = int(min=1, default=1535)
+lmin = integer(min=0, default=10)
+lmax = integer(min=1, default=1535)
# Directory contains the input data, e.g., component templates
# NOTE: This config is mandatory and should be provided by the user.
@@ -44,7 +44,7 @@ unit = option("MHz", default="MHz")
type = option("custom", "calc", default="custom")
# The frequency values to be simulated if above "type" is "custom".
-frequencies = force_list(default=float_list(120.0))
+frequencies = float_list(default=list())
# Parameters to calculate the frequencies
# start and stop frequency value (both inclusive)