aboutsummaryrefslogtreecommitdiffstats
path: root/fg21sim/configs/20-extragalactic.conf.spec
diff options
context:
space:
mode:
authorAaron LI <aly@aaronly.me>2017-07-20 16:03:23 +0800
committerAaron LI <aly@aaronly.me>2017-07-20 16:10:46 +0800
commit038d47dbff7f5fb536386f7b9e4f5de3141136ba (patch)
treebeb79c310020d8712c2d1124f9da89a8019319f8 /fg21sim/configs/20-extragalactic.conf.spec
parent3b2fc9a3dfb14bcf2b2d7692eacd35129a37466e (diff)
downloadfg21sim-038d47dbff7f5fb536386f7b9e4f5de3141136ba.tar.bz2
clusters/main.py: Implement "_simulate_merger()"
Simulate the formation history of each cluster and identify the last/recent major merger event. Also add new configuration option "tau_merger" and tweak several configurations options. Signed-off-by: Aaron LI <aly@aaronly.me>
Diffstat (limited to 'fg21sim/configs/20-extragalactic.conf.spec')
-rw-r--r--fg21sim/configs/20-extragalactic.conf.spec28
1 files changed, 19 insertions, 9 deletions
diff --git a/fg21sim/configs/20-extragalactic.conf.spec b/fg21sim/configs/20-extragalactic.conf.spec
index 377bd27..0f797a8 100644
--- a/fg21sim/configs/20-extragalactic.conf.spec
+++ b/fg21sim/configs/20-extragalactic.conf.spec
@@ -16,13 +16,31 @@
[extragalactic]
- # Emissions from the clusters of galaxies
+ # Extended emissions from the clusters of galaxies
+ # The configurations in this ``[[clusters]]`` section may also be
+ # used by the following ``[[halos]]`` section.
[[clusters]]
# The clusters catalog derived from the Hubble Volume Project (CSV file)
catalog = string(default=None)
# Output the effective/inuse clusters catalog data (CSV file)
catalog_outfile = string(default=None)
+ # Minimum mass change of the main cluster to be regarded as a merger
+ # event instead of an accretion event.
+ # Unit: [Msun]
+ merger_mass_min = float(default=1e12, min=1e10, max=1e14)
+
+ # Mass ratio of the main and sub clusters, below which is regarded as
+ # a major merger event.
+ ratio_major = float(default=3.0, min=1.0, max=10.0)
+
+ # The merger timescale, which roughly describes the duration of the
+ # merger-induced disturbance (~2-3 Gyr). This timescale is much longer
+ # the merger crossing time (~1 Gyr), and is also longer than the lifetime
+ # of radio halos.
+ # Unit: [Gyr]
+ tau_merger = float(default=3.0, min=1.0, max=5.0)
+
# The fraction that a cluster hosts a radio halo
halo_fraction = float(default=None, min=0.0, max=1.0)
@@ -51,14 +69,6 @@
# merger. (unit: Msun)
merger_mass_th = float(default=1e13, min=1e12)
- # Minimum mass change of the main-cluster to be regarded as a merger
- # event rather than accretion. (unit: Msun)
- merger_mass_min = float(default=1e12, min=1e10)
-
- # Mass ratio of the main and sub clusters, below which is regarded as
- # a major merger event.
- ratio_major = float(default=3.0, min=1.0, max=10.0)
-
# Radius of the giant radio halo in clusters (unit: kpc)
# XXX: currently only support a constant radius of halos
radius = float(default=500.0, min=100.0)