diff options
author | Aaron LI <aaronly.me@outlook.com> | 2016-10-29 22:55:15 +0800 |
---|---|---|
committer | Aaron LI <aaronly.me@outlook.com> | 2016-10-29 22:55:15 +0800 |
commit | 5f15114452c9ba70d965ef36e46df410621b1caa (patch) | |
tree | 76d17da1f316d15f641e0a97db3dd93353f01d75 /setup.py | |
parent | 0a99b0808741b6fdffcfdb8dc40c3c63f2aa7f5d (diff) | |
download | fg21sim-5f15114452c9ba70d965ef36e46df410621b1caa.tar.bz2 |
setup.py: Add "zip_safe=False" to avoid installing as a zipped egg
The upcoming Web UI based on Tornado needs direct access to the
templates/pages and static files, therefore avoid installing the package
as a zipped egg.
Also add a reference on "steuptools".
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 5 |
1 files changed, 5 insertions, 0 deletions
@@ -8,6 +8,8 @@ # https://packaging.python.org/ # [2] pytest - Good Integration Practices # http://doc.pytest.org/en/latest/goodpractices.html +# [3] setuptools: Building and Distributing Packages with Setuptools +# https://setuptools.readthedocs.io/en/latest/setuptools.html # import os @@ -70,6 +72,9 @@ setup( ], packages=find_packages(exclude=["docs", "tests"]), include_package_data=True, + # Do NOT installed as a zipped egg, since Tornado requires direct access + # to the templates and static files. + zip_safe=False, scripts=[ "bin/fg21sim", "bin/healpix2hpx", |