aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAaron LI <aaronly.me@outlook.com>2016-10-24 22:21:31 +0800
committerAaron LI <aaronly.me@outlook.com>2016-10-24 22:21:31 +0800
commit200ac8cdc3661af0306b85d7589a13759a66ee41 (patch)
tree4fb517aea9812bb891774510daf41207692530ec /setup.py
parent5fa8d50cbf9aacbc846cf650d1cbd2ec9fd0b5a3 (diff)
downloadfg21sim-200ac8cdc3661af0306b85d7589a13759a66ee41.tar.bz2
convert.py: Optimize "Fnu_to_Tb()" and "Sb_to_Tb()"
* Optimize the "Fnu_to_Tb()" and "Sb_to_Tb()" functions by explicitly calculating the conversions, avoiding the slow `astropy.unit` conversions (which is rather slow). The new fast functions are named as "Fnu_to_Tb_fast()" and "Sb_to_Tb_fast()". * Optimize the new functions using `numba.jit` further. * Add `numba` to the dependencies.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b7725e3..1fce5c6 100755
--- a/setup.py
+++ b/setup.py
@@ -80,6 +80,7 @@ setup(
],
install_requires=[
"numpy",
+ "numba",
"scipy",
"pandas",
"astropy",