aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAaron LI <aaronly.me@outlook.com>2016-09-30 16:54:53 +0800
committerAaron LI <aaronly.me@outlook.com>2016-09-30 16:54:53 +0800
commit83dc981ce37689d121db72d0a882d192e4b48bec (patch)
treed31f5e1a8c4fbac5fa8decbadffb2f5801a1dee3 /setup.py
parent11b60e1c5b9bb5292322645b84d2f5d16118d211 (diff)
downloadfg21sim-83dc981ce37689d121db72d0a882d192e4b48bec.tar.bz2
setup.py: Check Python >= 3.4 before installation
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9f5d0b2..1d8a7e3 100755
--- a/setup.py
+++ b/setup.py
@@ -6,6 +6,7 @@
#
import os
+import sys
from setuptools import setup, find_packages
@@ -16,6 +17,11 @@ def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
+# Check the minimal Python version
+if sys.version_info < (3, 4):
+ sys.exit("Sorry, Python >= 3.4 is required...")
+
+
setup(
name=pkg.__pkgname__,
version=pkg.__version__,