aboutsummaryrefslogtreecommitdiffstats
path: root/fg21sim/configs/config.spec
diff options
context:
space:
mode:
authorAaron LI <aly@aaronly.me>2019-01-25 16:17:23 +0800
committerAaron LI <aly@aaronly.me>2019-01-25 16:17:48 +0800
commit2ad2169909838a6a8055fc69541a1cde8ffe8391 (patch)
tree2f1ae8641f62cf7d8ab731637b66af1df694e25d /fg21sim/configs/config.spec
parent8ab2148f9871920e81562a88f491456fcca4b8b5 (diff)
downloadfg21sim-2ad2169909838a6a8055fc69541a1cde8ffe8391.tar.bz2
clusters/halo: Account for mass scaling in tau_acceleration()
Add configuration option "mass_index" to specify the scaling index.
Diffstat (limited to 'fg21sim/configs/config.spec')
-rw-r--r--fg21sim/configs/config.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/fg21sim/configs/config.spec b/fg21sim/configs/config.spec
index adc4134..f68b2e1 100644
--- a/fg21sim/configs/config.spec
+++ b/fg21sim/configs/config.spec
@@ -398,6 +398,10 @@ stream = option("stderr", "stdout", "", default="stderr")
# Electron injection, which is assumed to have a constant injection
# rate and a power-law spectrum.
injection_index = float(default=2.3, min=2.1, max=3.0)
+ # The scaling index of the diffusion coefficient (D_γγ) w.r.t. the
+ # mass of the main cluster.
+ mass_index = float(default=0, min=0, max=2)
+
# Minimum and maximum Lorentz factor (i.e., energy) of the relativistic
# electron spectrum.