aboutsummaryrefslogtreecommitdiffstats
path: root/fg21sim/configs/config.spec
diff options
context:
space:
mode:
authorAaron LI <aly@aaronly.me>2019-02-27 21:58:44 +0800
committerAaron LI <aly@aaronly.me>2019-02-27 23:57:12 +0800
commit963f6f4015c856f2f695f3634b47ed903ade5adf (patch)
treebdee4f28979d9d72bc57dc6b0eb41b82a75fc3b7 /fg21sim/configs/config.spec
parent39ac9e6c8bde34f78e7e520b04d7f2eae90e7795 (diff)
downloadfg21sim-963f6f4015c856f2f695f3634b47ed903ade5adf.tar.bz2
clusters/main: Implement _identify_halos() to determine genuine halos
New configuration options 'extragalactic/halos/genuine_{emfacc,index}_th' are added to set the thresholds.
Diffstat (limited to 'fg21sim/configs/config.spec')
-rw-r--r--fg21sim/configs/config.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/fg21sim/configs/config.spec b/fg21sim/configs/config.spec
index fd45949..5a0731d 100644
--- a/fg21sim/configs/config.spec
+++ b/fg21sim/configs/config.spec
@@ -456,3 +456,8 @@ stream = option("stderr", "stdout", "", default="stderr")
f_rc = float(default=0.1)
# The slope parameter (i.e., beta).
beta = float(default=0.6667)
+
+ # The emissivity acceleration factor and spectral index thresholds for
+ # determining whether the halo is genuine/formed.
+ genuine_emfacc_th = float(default=100)
+ genuine_index_th = float(default=3.5)