aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAaron LI <aly@aaronly.me>2018-10-31 16:36:23 +0800
committerAaron LI <aly@aaronly.me>2018-10-31 16:36:23 +0800
commit01c61b6b3c9eb8c1d5723d4f9ca9da12b7a3d0be (patch)
tree0142f8520ff54ee923d04a33d433d8b1dfd51fdd /setup.py
parentc84b208aefd0a500091aeb1e40507dde91412aa4 (diff)
downloadfg21sim-01c61b6b3c9eb8c1d5723d4f9ca9da12b7a3d0be.tar.bz2
Remove the empty tests
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py28
1 files changed, 2 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index fbe5a12..e598510 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python3
#
-# Copyright (c) 2016-2017 Weitian LI <weitian@aaronly.me>
+# Copyright (c) 2016-2018 Weitian LI <wt@liwt.net>
# MIT license
#
# References:
@@ -16,35 +16,14 @@ import os
import sys
from setuptools import setup, find_packages
-from setuptools.command.test import test as TestCommand
import fg21sim as pkg
-class PyTest(TestCommand):
- user_options = [("pytest-args=", "a", "Arguments to pass to pytest")]
-
- def initialize_options(self):
- TestCommand.initialize_options(self)
- self.pytest_args = []
-
- def finalize_options(self):
- TestCommand.finalize_options(self)
- self.test_args = []
- self.test_suite = True
-
- def run_tests(self):
- # import here, cause outside the eggs aren't loaded
- import pytest
- errno = pytest.main(self.pytest_args)
- sys.exit(errno)
-
-
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
-# Check the minimal Python version
if sys.version_info < (3, 4):
sys.exit("%s requires Python >= 3.4 ..." % pkg.__pkgname__)
@@ -58,8 +37,7 @@ setup(
author_email=pkg.__author_email__,
url=pkg.__url__,
license=pkg.__license__,
- # Trove classifiers
- # See: https://pypi.python.org/pypi?%3Aaction=list_classifiers
+ # Trove classifiers (https://pypi.python.org/pypi?%3Aaction=list_classifiers)
classifiers=[
"Development Status :: 4 - Beta",
"Environment :: Console",
@@ -99,6 +77,4 @@ setup(
dependency_links=[
"git+https://github.com/astropy/regions.git",
],
- tests_require=["pytest"],
- cmdclass={"test": PyTest},
)