aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAaron LI <aly@aaronly.me>2017-10-04 20:57:56 +0800
committerAaron LI <aly@aaronly.me>2017-10-04 20:57:56 +0800
commit0fe535c2ccbe408c37a6c54629c507c2788485b9 (patch)
tree75874e2df7fdb21c309f489dc6d3f2972df64434 /setup.py
parentfcc461d3432b8c3dd417467e813ae934277b2171 (diff)
downloadfg21sim-0fe535c2ccbe408c37a6c54629c507c2788485b9.tar.bz2
clusters: Use "hmf" to calculate halo mass functions/distributions
* New dependency "hmf" (halo mass functions) module * Calculate halo mass distributions/functions (dndlnm) with respect to masses and redshifts, instead of use the previous data file ("ps_data") * New section "[extragalactic][psformalism]" in configurations * New functions to write and read the dndlnm data TODO: * update the method to sample (mass, redshift) for clusters from the dndlnm data
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 63ef7b0..00bd96e 100755
--- a/setup.py
+++ b/setup.py
@@ -89,6 +89,7 @@ setup(
"requests",
"tornado",
"reproject",
+ "hmf",
],
dependency_links=[
"git+https://github.com/astropy/regions.git",