aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAaron LI <aaronly.me@outlook.com>2017-05-22 14:21:47 +0800
committerAaron LI <aaronly.me@outlook.com>2017-05-22 14:21:47 +0800
commit42a173830b9f47868e7b08f0c7474699ecbe05b6 (patch)
tree2a0a533d27fc4f253ef0b28c86c13763ac3719ae /setup.py
parentd2c9dd2601d312077c11ca0a36ef02429b1bfbfc (diff)
downloadfg21sim-42a173830b9f47868e7b08f0c7474699ecbe05b6.tar.bz2
Add new dependence "astropy/regions" from GitHub
Credit: * Adding git (or hg, or svn) dependencies in setup.py (Python) https://mike.zwobble.org/2013/05/adding-git-or-hg-or-svn-dependencies-in-setup-py/ * Python Dependencies via Pip https://devcenter.heroku.com/articles/python-pip
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6b0feb2..626dbb0 100755
--- a/setup.py
+++ b/setup.py
@@ -96,6 +96,9 @@ setup(
"requests",
"tornado",
],
+ dependency_links=[
+ "git+https://github.com/astropy/regions.git",
+ ],
tests_require=["pytest"],
cmdclass={"test": PyTest},
)