aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAaron LI <aaronly.me@outlook.com>2016-09-25 15:56:28 +0800
committerAaron LI <aaronly.me@outlook.com>2016-09-25 15:56:28 +0800
commit55309d828657ff7abe4f839743020059fd89bfbb (patch)
tree85816cf4387a926edf34e34bb7a0d46d4ac7324f /setup.py
parent2225a263cb9ce66b58c5269a43f4482369b63298 (diff)
downloadfg21sim-55309d828657ff7abe4f839743020059fd89bfbb.tar.bz2
Add logging and update setup configs
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index dc40675..a0ca71f 100755
--- a/setup.py
+++ b/setup.py
@@ -1,9 +1,15 @@
#!/usr/bin/env python3
# -*- coding: utf-8 -*-
+import re
+
from setuptools import setup, find_packages
+with open('fg21sim/__init__.py') as f:
+ version = re.search(r'^__version__\s*=\s*[\'"]([^\'"]*)[\'"]',
+ f.read(), re.MULTILINE).group(1)
+
with open('README.rst') as f:
readme = f.read()
@@ -12,7 +18,7 @@ with open('LICENSE') as f:
setup(
name='fg21sim',
- version='0.0.1',
+ version=version,
description='Realistic Foregrounds Simulation for EoR 21cm Signal Detection',
long_description=readme,
author='Weitian LI',