aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAaron LI <aly@aaronly.me>2017-05-31 22:49:53 +0800
committerAaron LI <aly@aaronly.me>2017-05-31 22:49:53 +0800
commit6f286557c1cd0dd3948d8199123d0820e2b9e65e (patch)
treeba908301607aa09a1e59c90ee762fb81910effa7 /setup.py
parente21529e00f7aaae480a3f0d5259c21627e8752be (diff)
downloadfg21sim-6f286557c1cd0dd3948d8199123d0820e2b9e65e.tar.bz2
setup.py: Use `os.listdir("bin/")` to obtain all executables
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 1 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 6fffb2c..fd80c81 100755
--- a/setup.py
+++ b/setup.py
@@ -75,16 +75,7 @@ setup(
# Do NOT installed as a zipped egg, since Tornado requires direct access
# to the templates and static files.
zip_safe=False,
- scripts=[
- "bin/fg21sim",
- "bin/fg21sim-download-cluster-data",
- "bin/fg21sim-download-snr-data",
- "bin/fg21sim-webui",
- "bin/get-healpix-patch",
- "bin/healpix2hpx",
- "bin/hpx2healpix",
- "bin/zea2healpix",
- ],
+ scripts=os.listdir("bin/"),
install_requires=[
"numpy",
"numba",