aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAaron LI <aaronly.me@outlook.com>2016-09-20 17:28:55 +0800
committerAaron LI <aaronly.me@outlook.com>2016-09-20 17:28:55 +0800
commit8e0aad8633ea3484a5a679fef6d04f7249f1400a (patch)
treee7d965f74d10674ec539531aed8feec68d5a17f4 /setup.py
parent393f6b3833e5ce1a197d507e628f7452de1b65a3 (diff)
downloadfg21sim-8e0aad8633ea3484a5a679fef6d04f7249f1400a.tar.bz2
Setup package structures
Credit: https://github.com/kennethreitz/samplemod TODO: Add the 'docs' part
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..dc40675
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/env python3
+# -*- coding: utf-8 -*-
+
+from setuptools import setup, find_packages
+
+
+with open('README.rst') as f:
+ readme = f.read()
+
+with open('LICENSE') as f:
+ license = f.read()
+
+setup(
+ name='fg21sim',
+ version='0.0.1',
+ description='Realistic Foregrounds Simulation for EoR 21cm Signal Detection',
+ long_description=readme,
+ author='Weitian LI',
+ author_email='liweitianux@live.com',
+ url='https://github.com/liweitianux/fg21sim',
+ license=license,
+ packages=find_packages(exclude=('tests', 'docs'))
+)