diff options
author | Aaron LI <aly@aaronly.me> | 2017-11-16 11:13:41 +0800 |
---|---|---|
committer | Aaron LI <aly@aaronly.me> | 2017-11-16 11:13:41 +0800 |
commit | fb81cd70c031272d8deaf1c5dc3bb68f0d2c9f1c (patch) | |
tree | 7a2f8695c8c8f216aa3e7cd3661dbfb78468de73 /setup.py | |
parent | 920c72c05499c91024b6311a62836bd4cc9e0d84 (diff) | |
download | fg21sim-fb81cd70c031272d8deaf1c5dc3bb68f0d2c9f1c.tar.bz2 |
setup.py: improve trove classifiers
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 8 |
1 files changed, 6 insertions, 2 deletions
@@ -46,7 +46,7 @@ def read(fname): # Check the minimal Python version if sys.version_info < (3, 4): - sys.exit("Sorry, Python >= 3.4 is required...") + sys.exit("%s requires Python >= 3.4 ..." % pkg.__pkgname__) setup( @@ -58,12 +58,16 @@ setup( author_email=pkg.__author_email__, url=pkg.__url__, license=pkg.__license__, + # Trove classifiers + # See: https://pypi.python.org/pypi?%3Aaction=list_classifiers classifiers=[ - "Development Status :: 2 - Pre-Alpha", + "Development Status :: 3 - Alpha", "Environment :: Console", "Intended Audience :: Science/Research", "License :: OSI Approved :: MIT License", "Natural Language :: English", + "Operating System :: MacOS :: MacOS X", + "Operating System :: POSIX :: BSD", "Operating System :: POSIX :: Linux", "Programming Language :: Python :: 3 :: Only", "Programming Language :: Python :: 3.4", |