aboutsummaryrefslogtreecommitdiffstats
path: root/fg21sim/configs/00-general.conf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'fg21sim/configs/00-general.conf.spec')
-rw-r--r--fg21sim/configs/00-general.conf.spec8
1 files changed, 8 insertions, 0 deletions
diff --git a/fg21sim/configs/00-general.conf.spec b/fg21sim/configs/00-general.conf.spec
index 0f9f048..bed3a70 100644
--- a/fg21sim/configs/00-general.conf.spec
+++ b/fg21sim/configs/00-general.conf.spec
@@ -12,6 +12,8 @@
# HEALPix N_side value, i.e., pixel resolution
# NOTE: also update "lmax" below.
nside = int(min=1, default=512)
+# HEALPix ordering scheme
+ordering = option("RING", "NESTED", default="RING")
# Range of multipole monents (l) of the angular power spectrum.
# The power spectrum will be cut off to a constant for multipole l < lmin.
@@ -48,6 +50,9 @@ frequencies = force_list(default=float_list(120.0))
# Unit of the sky map pixel value
unit = option("K", default="K")
+# Use single-precision float instead of double (also save spaces)
+use_float = boolean(default=True)
+
# Filetype used to store the products (default: fits)
filetype = option("fits", default="fits")
@@ -55,6 +60,9 @@ filetype = option("fits", default="fits")
# be finally formatted using `str.format()`.
filename_pattern = string(default="{prefix}_{frequency:.1f}")
+# Overwrite existing files
+clobber = boolean(default=False)
+
# Whether combine all components and output
combine = boolean(default=True)
# Prefix for the combined files