aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..dc40675
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/env python3
+# -*- coding: utf-8 -*-
+
+from setuptools import setup, find_packages
+
+
+with open('README.rst') as f:
+ readme = f.read()
+
+with open('LICENSE') as f:
+ license = f.read()
+
+setup(
+ name='fg21sim',
+ version='0.0.1',
+ description='Realistic Foregrounds Simulation for EoR 21cm Signal Detection',
+ long_description=readme,
+ author='Weitian LI',
+ author_email='liweitianux@live.com',
+ url='https://github.com/liweitianux/fg21sim',
+ license=license,
+ packages=find_packages(exclude=('tests', 'docs'))
+)